This project has moved and is read-only. For the latest updates, please go here.

Poll on naming convention

Jul 7, 2011 at 5:34 AM

What do you guys like best?

var row1 = row2.RowAbove();
var row3 = row2.RowBelow();

or

var row1 = row2.Previous();
var row3 = row2.Next();

I like the sound of row.Next() but it feels too much like recordset nomenclature where the ".Next()" advances the record reference of the current object but it doesn't return anything. It seems the ".Next()" is better suited for the following case:

var row = worksheet.Row(2);
row.Next();
Console.WriteLine(row.RowNumber()); // Prints 3

On the other hand I like row.RowBelow() because it's very "discoverable".

What do you guys think?

 

btw, yes... these are the kind of things that keep me awake at night.

Jul 7, 2011 at 3:49 PM

I vote for RowAbove and RowBelow

Jul 14, 2011 at 3:42 PM

I vote for the RowBelow() convention, because of the aforementioned discoverability.