This project has moved. For the latest updates, please go here.

Bug in latest version

Jan 13, 2011 at 4:29 PM
Edited Jan 14, 2011 at 8:27 AM

Hi,

 

I have an excel sheet that worked on the previous version but on the 0.40 build just opening and saving the file damages it. Can you tell me where I can send the file so you can have a look at it?

 

Regards

Coordinator
Jan 13, 2011 at 4:49 PM

I'm sorry that it happened.

If the file doesn't contain sensitive information then please open a ticket on the Issue Tracker tab and attach the file.

If you want more privacy then email it to "manuel at manueldeleon.com"

Jan 14, 2011 at 8:27 AM

I created the item on the Issue Tracker with the affected file.

Coordinator
Jan 14, 2011 at 11:16 PM
Edited Jan 15, 2011 at 7:02 AM

The file saves/loads okay on v0.41 but I noticed the Anual and Mês values lost their format. I'll work on it...

Coordinator
Jan 16, 2011 at 4:06 AM

Both issues are fully fixed, the file loads and it now retains the formatting that was lost.

Jan 17, 2011 at 9:33 AM

Thanks for fixing the file open issue but I still get a different cell format when saving with ClosedXml. It's like all numbers are multiplied by 100. Check the following screenshots at http://img251.imageshack.us/g/modified.png/

Coordinator
Jan 17, 2011 at 7:35 PM
I don't have that problem on my machine. What locale are you using?
Jan 18, 2011 at 9:09 AM

I use Portugal locale.

http://img209.imageshack.us/i/24542714.png/

Coordinator
Jan 18, 2011 at 4:03 PM

I tried with both Portuguese Portugal and Brazil and the number format is just fine. Are you doing anything with the file before saving it back? Right now all I'm doing is opening and then saving the file you gave me.

Let me know...

Jan 18, 2011 at 5:04 PM

I'm also just opening the file and saving it. I tried doing it with English (US) locale and the file opens fine. I dunno why you can't replicate it on your machine. The problem is surely with the number format because we use commas to separate decimals instead of dots.

Coordinator
Jan 18, 2011 at 5:12 PM

I'll try again...

Coordinator
Jan 19, 2011 at 3:45 AM

I really can't reproduce it. Please attach a file saved with Portuguese settings and another one saved with English settings. This way I can compare your outputs and maybe figure out what's going on.

Jan 20, 2011 at 12:08 PM

I created a Virtual Box virtual machine that replicates the problem. I will send you via mail the login details so you can download it. Is that ok?

Coordinator
Jan 20, 2011 at 4:11 PM

Sure thing, I'll be happy to take a look and fix it. Send me the info.

Coordinator
Jan 21, 2011 at 6:22 AM

Thanks for the VM, it helped me realize what I was doing wrong and I was able to reproduce the error on my box.

The problem was that when CloseXML opened a file, it picked up the numbers without processing them (in a culture invariant format). Later on when you saved the file it assumed the numbers were in the culture of the machine.

I really wonder why our German friends didn't pick this one up before...

Anyway, it's now fixed on v0.42.1 (it now loads numbers into the culture of the machine)

Thanks again for your help,

Jan 21, 2011 at 9:01 AM

Thank you for fixing the number format problem!

Now I found another problem with formulas on the same file. The formula on the sheet Tarifas!G35 should be =(G29*$B$22)/1000 but after opening and saving it is =(G28*$B$22)/1000

Other cells have the same problem but I guess fixing for that one will fix for them all.

 

 

Coordinator
Jan 21, 2011 at 4:04 PM

I'll get to it...

Coordinator
Jan 22, 2011 at 3:57 AM
Edited Jan 22, 2011 at 7:08 AM

-deleted-

I found the problem.

Coordinator
Jan 22, 2011 at 8:48 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Jan 23, 2011 at 2:57 AM

Fixed it. The changes will appear on v0.43

Thanks,